Invoices Missing
Incident Report for SpringboardVR
Resolved
All Invoices and Statements have been fixed and are available for download again.
Posted Jul 06, 2023 - 13:20 UTC
Investigating
Currently, all invoices prior to 1st July 2023 are not appearing in Operator Panels. We are investigating this and hope to have it rectified in the next 24-48hrs and will update as we get more information.
Posted Jul 05, 2023 - 17:08 UTC
This incident affected: Services (Operator Panel).