SpringboardVR Menus non-functional due to SteamVR update
Incident Report for SpringboardVR
Resolved
The bug was fixed. The change is now live in the public release of SteamVR, version 1.21.11.
The previous version v1.20.4public in BETAS has been deleted by Valve and it should say now ¨None¨ when you view BETAS.
Automatically version should be updated to 1.21.11 which is compatible with SpringboardVR.
Reach out to support@springboardvr.com if you require further assistance.
Thank you for your patience!
Posted Mar 09, 2022 - 17:54 UTC
Update
Hi Everyone,

We have received news from Valve that they've identified the bug on their end in SteamVR that caused this issue and hope to have a new version of SteamVR that fixes this out in the next 24-48hrs. We will let you know when this has been implemented and it is safe to switch back to the main branch but for now please remain with the 1.20.4 version.
Posted Mar 01, 2022 - 05:08 UTC
Update
We have identified the issue and are working out a permanent fix, please follow instructions below to revert to earlier version of SteamVR as a temporary fix:
Open Steam then find SteamVR, right click and select properties, navigate to the Beta Section you will be able to select "v1.20.4public - previous", this will revert your SteamVR to the previous version. Please make note that when this issue is resolved you'll need to select this back to "None" to return to the main branch. Thank you again for your patience and we'll have further updates when available
Posted Feb 24, 2022 - 01:19 UTC
Update
All customers now have a temporary fix available, if you open Steam then find SteamVR, right click and select properties, navigate to the Beta Section you will be able to select "v1.20.4public - previous", this will revert your SteamVR to the previous version. Please make note that when this issue is resolved you'll need to select this back to "None" to return to the main branch. Thank you again for your patience and we'll have further updates when available.
Posted Feb 23, 2022 - 07:51 UTC
Update
We've made contact with SteamVR Developers directly and will be working with them to find a solution to this as quickly as possible. We'll update with more information the moment we have it.
Posted Feb 23, 2022 - 02:02 UTC
Identified
At this moment we have identified the problem and we are working on a resolution for SpringboardVR Game Menu in the Launcher.

In the Interim we have some solutions to recommend:

1) Use the Remote Launch function via the Monitor
2) Start games via Desktop Shortcuts/ Windows Search Bar with the SpringboardVR icon
3) At your own discretion: head over to Steam and select the oculus_win7and8 v1.15.12 version in the SteamVR properties / BETAS. This will allow you to have the Game Menu working, but we are not sure of potential compatibility issues with the games due to this version change.

There will be an update within the next 24hrs with more information! Thank you for your patience and understanding.
Posted Feb 22, 2022 - 19:12 UTC
Investigating
We are aware that the current SteamVR update has created an issue where the menu inside the launcher has become non-interactable. We are investigating this as our top priority and will update with information as soon as we have it.

In the mean time you are still able to launch using the Remote Launch function or by searching for the title in the Windows Search Bar and selecting the one with the SpringboardVR logo next to it.
Posted Feb 22, 2022 - 11:54 UTC
This incident affected: Services (VR Launcher and Services).